Unable to get "go get" to work - invalid repository name

I’m trying to get the mysql package from git, however, I keep getting the following error:

> go get -u -v github.com/go-sql-driver/mysql
github.com/go-sql-driver/mysql (download)
# cd .; git clone https://github.com/go-sql-driver/mysql /root/go/src/github.com/go-sql-driver/mysql
Cloning into '/root/go/src/github.com/go-sql-driver/mysql'...
fatal: remote error:
  /go-sql-driver/mysql is not a valid repository name
  Email support@github.com for help

github support, so far, has been unable to help me.

I’ve also tried the git clone command with the same results.

I’m on a server running CentOS Linux release 7.1.1503 (Core) and have git version 2.20.1 installed.


I can’t reproduce this. You have a farly old version of Centos 7. Current version is CentOS Linux release 7.6.1810 (Core). Can you update?

And the version of git on the latest version is So you have installed a newer one. Could you test with the version from the centos repo?

I updated my OS to CentOS Linux release 7.6.1810 (Core) and downloaded and installed git version
I am getting the same error message as before.

Are you using some git configuration? some like that below

git config set 'https://'.insteadOf ...

I added wandisco-git.repo in my /etc/yum.repos.d directory with the contents:

name=Wandisco GIT Repository

This enabled me to load git version

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.