Package custom domain

Hi all.

When I Create custom domain for my package like this

<meta name="go-import" content=" git" />
<meta name="go-source" content="{/dir}{/dir}/{file}#L{line}" />

then I try go get in new project I have some error like this

go get                                                                                                                                                  ─╯
go: downloading v0.0.1
go: verifying module: reading 404 Not Found
        server response:
        not found: invalid version: git ls-remote -q origin in /tmp/gopath/pkg/mod/cache/vcs/68810a2e811d4b05ff603d5d5704409f3cd5eacd82dd5d2038f869ef899160dc: exit status 128:
                fatal: could not read Username for '': terminal prompts disabled
        Confirm the import path was entered correctly.
        If this is a private repository, see for additional information.

what wrong with my configuration
Please help

Hi @Rusli_Nasir,

Two observations:

  1. The first error I see is a 404 not found when quering the Chinese Go sum database:

The subsequent error message reveals that the Go sum DB at tries to access

I have no idea why the proxy fiddles with GitLab when the import path resolves to GitHub. But in any case, v0.0.1 does not seem to exist anyway. (I tried go get and got an invalid version error.) MAYBE try a different Go proxy.

  1. When I run the go get command, I get a different error (for a different version):
> go get                                                                                                                                                       0s
go: downloading v0.13.2
go: (v0.13.2) requires parsing go.mod:
	module declares its path as:
	        but was required as:

This one should be easy to fix: Replace the module path in your go.mod file with the vanity import path:


You might need to bump the version after that change, in order to update the proxy.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.