My tags not recognized on github

My tags do not seem to be recognized at least by golang.
when I use go list command to check my modules, it reports error

>go list -m
go list -m: module no matching versions for query "v1.0"

while I can do the same to others’ modules, like

>go list -m v0.0.0-20191115235526-e229bcc9c747

But I do not see any difference between my tag and the reference project’s. Also wonder whether it is a github issue or golang issue. Thanks a lot.

As far as I understand it, a version is required to follow semantic versioning, which again is specified to use 3 segments. Your tag has only 2.

I created a new version “1.0”, not “v1.0” and it worked.
but other modules still does not take this version as latest,


go 1.14

require v0.0.0-20201120054256-b5ba9c3ab6c5

1.0 still only has 2 segments, have you tried a version with 3 segments?

1.0.0 works the same
and has v, yet it works. So there must be something I’m still wrong.

>go list -m v0.1.0

maybe it was because my connection did not work and I was always using my cache… But github remembers my previous tags even after I removed them using git command and they were no more shown on the web.

  1. remove the repository and recreate one
  2. upload the files
  3. make a tag v0.0.1 on the web

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.