Modules problem involving `` [SOLVED (but I don't see how!)]

  • macOS 10.14.6
  • go version go1.15.5 darwin/amd64

I’m trying to build the package, using the command go build .... It runs through a scary amount of dependency/module related messages before falling down with…

go: imports parsing go.mod:
	module declares its path as:
	        but was required as:

A spot of research reveals that this is a problem that occurred because the authors of nats-io introduced a breaking change in a path or file setting. I think this was the case, at least… whenever I get go modules related errors, my mind clouds over and I get the image of Russ Cox telling everyone that it’s all working to plan :open_mouth:

I’ve tried some of the suggested fixes, but maybe they are out of date, but nothing seems to work.

Can anyone spell out in simple terms how I can get to build?

UPDATE: Strangely, if I load the main.go file in VS Code, configured to run with go 1.15.5, the build succeeds. VS Code must be doing something to mitigate the modules problem…

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.