Integrating with google cloud datastore

Hello. I have a go module where I am trying to integrate with google cloud store. I am using go v1.14. When I do go get on the cloud datastore, it gives the following error.

go: upgrade => v1.1.0
go get: requires requires requires verifying module: malformed record data

Below are the contents of my go.mod file

module <MyNamespace>.com/<moduleName>

go 1.14

require ( v1.5.1

I don’t really understand the error. Could someone please help me out in understanding it?

I can’t reproduce your problem. Give an new module

module de.lhorn/forum

go 1.13

require v1.1.0

require v1.5.1

and a main.go like

package main

import (
        _ ""
        _ ""

func main() {

running go build . works as expected. It downloads the required modules and their dependencies and builds the executable.

Since you are using modules, try to run go build . instead of go get.

Thanks @lutzhorn for your response.

I just found the problem. The update was conflicting with some local cache that was downloaded. After clearing the cache, I was able to run it with go get.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.