Installer for 1.21.6 on Windows 11 just says "Ended prematurely because of an error" with no other information

I’m on Windows 11, and I tried to install the latest Go (1.21.6). I had installed 1.17.6 about a year ago, but I wanted to replace that with the latest.

I downloaded the installer and started it, and when I clicked on the final “Install” button, it quickly brought up the next dialog saying “Go Programming Language amd64 go 1.21.6 Setup Wizard ended prematurely because of an error.” It provides no other information. I tried this multiple times with the same result. I tried running it both as an Administrator and not. No difference.

Actually, I think I had 1.17.3 installed, not 1.17.6.

I was able to complete the 1.17.3 installation, but I realize now that I downloaded the 386 variant, and I I had the amd64 variant before. I’ve now tried running the installer for several newer versions, both 386 and amd64, and all of them fail with this “premature error”.

The Windows Control Panel is additionally confused. I tried uninstalling both the old amd64 install and the new 386 install, and both of them silently ignore my attempt to uninstall it.

Why can’t they just provide a zip, similar to the tar.gz for the Linux version? Installing the 1.21.6 zip in my Linux VM went flawlessly, but using my Linux VM for this isn’t as convenient as I would like.