How to fix this?

Thanks.

did you update?

I did and it seems to hang and not complete.

How to do it manually ?

installation in progress would show an error
but in general tools to install go get -u golang.org/x/tools/
or clone manually from the official git repository to where your tools lie default $GOPATH/src/golang.org/x/tools

I did that command it I still get the same error.
Why is VSC trying to install in go/bin and you said to put it in go/src ?

Fixed it. just had to change the go extension settings for FORMAT TOOL from goreturns to goimports. thanks.

Glad that you figured it out, you misunderstood me, this is the path from where the installation comes from, and the installation

I installed the tools in both /src and /bin with both “go get” and “git clone” for the go/tools github repo and it didn’t work. the fix I mentioned above was the right way.

Thanks.

The question would be more SEO friendly if you title it with the error you’re getting. @PaulGureghian

I fixed it now. but I will make a better title next time.

Thanks.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.