Having trouble installing Golang Lint on Windows


I am new golang user. I have started to write Go code. Thanks to @toddmcleod’s tutorials I am progressing well.

There has been some Odd issue with the installation of Golint tool in windows.

My Go PATH is set to C:\local\04_Go-ws where I store all my repositories and sources.
When I run the command go get -u github.com/golang/lint/golint It types out a error as below:

package golang.org/x/tools/go/gcimporter15: directory "C:\\local\\04_Go-ws\\src\\golang.org\\x\\tools\\go\\gcimporter15" is not using a known version control system

Then I tried to install the gcimporter15 package: go get golang.org/x/tools/go/gcimporter15

And I still get:
package golang.org/x/tools/go/gcimporter15: C:\local\04_Go-ws\src\golang.org\x\tools exists but C:\local\04_Go-ws\src\golang.org\x\tools\.git does not - stale checkout?

Not sure whats wrong.
Also note that I use GitBash shell.
I have tried to do these with elevated permissions enabled as Administrator, still the same results.

Please help and let me know in case I am giving wrong commands.

rgds - AB

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.