Firebase installation issue JWT not found

We are trying to install firebase and we get an error no matter which linux machine we try to install it on.

(had to use a space after firebase in this post as the forum would let me post with extra links in the message)

Please advise what can be done to fix this so we can install and continue programming. Any help would be awesome! We never had any issues with installing anything for go.

[root@localhost ~]# go get firebase
cannot find package “” in any of:
/usr/lib/golang/src/ (from $GOROOT)
/root/go/src/ (from $GOPATH)

Using go version 1.19.9

github. com/golang-jwt/jwt is installed when we navigate to the /root/go/src/ folders

Tried to install github. com/golang-jwt/jwt/v4 however we get the same error above

1 Like

I’m facing the same issue when installing the Firebase Admin SDK with go get

I think this is related to me not using Go modules (GO111MODULE=off, aka GOPATH mode) and the firebase module depending on a v2+ version of the JWT package.

The Firebase team have decided to drop non-module support but I’d say the documentation does not reflect this decision.

I have tried using Go 1.16 and checking out an older Firebase version but it shows the same error.

Have you found any solution @Bob_Go ?

Retry the installation of the Firebase Go SDK using the command go get .

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.