Chrome for MS-Windows cannot load wasm code after refresh 4 times

I’m studying wasm with this page

Both Firefox and Edge(With Polyfill) have no problem.

Is there any solution or can I know what is my fault which caused this problem?

No one have met this situation?

Hi Robert,

I tried it and it worked for me. I’m using Linux, with Firefox 62.0.3 and Chrome 70.0.3538.67 browsers. Is it crashing on you after you click in the browser window? That’s what I tried, and I saw no problem.

One thing to be careful of is that Chrome (and maybe Firefox) may load the page from their cache, rather than from the server. Or it may load the new version of the app while keeping remnants of the old version.

So if you are having a weird problem, fully clear the browser cache like this:

  1. Open an empty tab
  2. Close the WebAssembly app tab
  3. Clear the browser cache
  4. Close the browser

Then reopen the browser to the WebAssembly app, and it will fully reload it from the web server.

Hello jayts,

You did same thing as I did.

Oops, sorry for missing which OS I’m using.

Here is my working environment.

  • CPU: AMD Ryzen 2700
  • RAM: 32G
  • OS: MS-Windows 10 Pro
  • Chrome: 70.0.3538.67 (updated some hours ago)
  • Firefox: developer edition 64.0b2 (latest)

I cleared browser cache as your mention then try again and got same result.

It seems to be shown similar situation with other wasm examples like this
This calc example seems to works well but, also crashs when do refresh current page 3 times after add, subtract button click

I uploaded a video for this.

Before 00:26 is the situation I asked.
After 00:26 is the situation when using syscall/js

I’m confusing where ask or report this to go or chrome.

Thank you for giving your time.

Hi Robert,

Just now I got the Calc source from the GitHub repository you linked to. After clearing the browser cache, that works for me, too.

In the video, I can’t see that you are doing anything wrong, but I’m not used to developing Go/WebAssembly on Windows, and I can’t read Korean.

At 00:17 in the movie shows that chrome is crashed.
The error message is same as picture in my first post.

Calc example is not in the above movie but, met same situation.
Sorry for make you confusing.

I will create movie again some hour later.
Need sleep.

Thank you for giving your time.

I recreated videos.

Try example from golang wiki -

Try calc example -

From both videos, you may see crash screens when click button or refresh in chrome.

Hi Robert,

Thanks very much for uploading the new videos. That helped a lot. I am using just the calc example, and I was able to reproduce the problem.

The app still works fine for me on Linux, but I started up a computer with Windows 7 and tried that, along with Firefox version 62.0.3, Chrome version 70.0.3538.67, and Opera version 56.0.3051.52 (the latest updates). With both Chrome and Opera (which is based on Chromium, which Chrome is based on), I’m seeing the same problem that you reported. Firefox runs the app with no problems.

What I see here is a little different from what you show to produce the problem.

First, I never see it happening unless the Developer Tools window is open. I am very happy about that because it means there is no problem (as far as I can tell) with deploying WebAssembly apps. Regular visitors to the web page are unaffected.

Second, I do not need to click on buttons before reloading. Some number of clicks on the browser’s Reload button cause the error. That’s all it takes for me. The number of clicks is not always the same. Sometimes it’s 4 clicks, but can be a different number.

By the way, it’s not that Chrome or Opera are crashing; it is just that they are unable to load the WebAssembly app. In Chrome, I’m seeing both the “Aw, Snap!”, and “Out of memory” errors you show in the video. In Opera, I see only the “Out of memory” error. And after the failure, another click on Reload cures the problem. So even then, the problem is not a really major one.

To further investigate, I tried serving the app with Apache 2 on my Linux system, both for the local Linux system and for the Windows 7 system over my LAN. So in this configuration, browsers running on both Linux and Windows are getting the app (exactly the same files) from the same server.

The result of that was that all three browsers on Linux run the calc example app with no problems, but on Windows, both Chrome and Opera suffer from the bug, while Firefox was fine.

This looks like a bug that started in the Chromium code base, and still exists in both Opera and Chrome.

I suggest that for now, you can use Firefox Developer Tools to develop your WebAssembly apps, and if you want, you can report a bug to the Chrome and Chromium developers.

I noticed this topic now has over 140 views, so I put the calc WebAssembly/Go example on my website. If you want to try running it, go here:

It is just a very simple example of a “calculator” that shows the sum or difference of two integers (it doesn’t work with floating point). Type the integers into the text fields at the top, then click on the Add or Subtract button to see the result in the lower text field.

To check for the bug, open the browser’s Developer Tools, then click on the browser’s Reload button many times. Let us know if you see a failure.

I’d especially like to hear from macOS/Safari users. On macOS, does the calc app work in all of Safari, Firefox, Chrome, and Opera? Can you reproduce the failure in Chrome and/or Opera?

I’m working on a more sophisticated Go WebAssembly app that will be a better test, and will also be more fun to play with, but for now, it would be great to have reports from forum members on how well Go’s support for WebAssembly is working on various platforms.


Hello @jayts .
Yes, you’re right.
Also I changed the title.

Looking forward your app.

Thank you for having your time.:grinning:

On mac os and loading

  • Chrome 70 works both with and without developer tools open. Reloaded about 8 times in each
  • Firefox 62.0.3 works. Tried both with and without developer tools
  • Safari 12.0 works. Tried both with and without developer tools

Sadly, the example at my first post on windows chrome still shows error Aw, Snap! with Developer tool is not opened.
I uploaded the example using run button at my personal website.

Thank you for having your time.

Hi Johan,

Thanks very much for trying it on macOS!

I also tried the calc example on my Android tablet, and it works using Firefox Beta (version 63) and Chrome. Anyone have an iPhone or iPad?

Hi Robert,

I apologize for not including the “run” example in my tests. It was a wrong assumption on my part that working with the more complicated example would suffice. (It’s just that my time is limited.)

I tried the “run” example on Linux, and it worked with Chrome, Firefox, and Opera. But on Windows, I am seeing “Aw, Snap!”, as you reported, and also “Out of memory” errors – with the Developer Tools window closed, and by clicking on the Run button, not just with the browser’s Reload button. And in fact it even crashed Chrome! (So maybe you can change the topic back to the original. :laughing: ) And I see that every 4th time the Run button is clicked, the error occurs.

I also get “Out of memory” errors on Opera, also by clicking on the app’s Run button 4 times.

When Chrome crashed, a dialog opened so I could submit a bug report, and I did that. (Twice, because later, it crashed again. :slight_smile: ) I hope that got their attention.

I changed the topic :laughing:

I hope that got their attention too.

Thank you for sharing your time.

1 Like

Update. 18, Dec 2018 : Almost not crash at 71.0.3578.98 but, few still crash.

Maybe solved the problem.

I have encountered a similar problem after switching pages frequently on windows chrome ,and the number is not fixed

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.