Can't install latest version on Debian


I’m trying to install the latest go version on Debian bullseye.

At first I followed instructions shown at this link Download and install - The Go Programming Language

But which go always returned /usr/bin.

Then I found this post that suggested removing go via apt-get Apt-get install golang, next? - #2 by calmh

And now I get command not found when I run go.

Check your PATH environment variable. Check that the go installation actually exists in the filesystem where you think it should.

1 Like

I found the issue.

I made sure that it was installed where I thought it was as you suggested. So I ran /usr/local/go/bin/go1.17.2 and got this error message go1.17.2: not downloaded. Run 'go1.17.2 download' to install to /home/me/sdk/go1.17.2

I then ran /usr/local/go/bin/go1.17.2 download and it downloaded some things and now I can call go1.17.2.

Although I don’t know why I had to do that since it’s not explained anywhere.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.