Problems upgrading to Golang 1.9.1 [SOLVED]

macOS 10.12.6 Sierra

Hello, I’ve just tried to upgrade my previously working Golang system from 1.9.0 to 1.9.1. Now when I attempt to use the go get command to download a package from I get the error message compile: version "go1.9.1" does not match go tool version "go1.9". All previous upgrades of Golang dating back to 1.6.0 have been entirely without problem or incident. What is different this time?

How did you upgrade?

I used the installer, which removed my go1.9 installation and installed go1.9.1 in its place.

I hadn’t tried go get until reading this post, at which time I ran my most recent one: go get -u It succeeded without errors.

I followed the instructions on this page including the bit about uninstalling the old version. I ran the installer in the usual way and didn’t notice anything different this time.

As an experiment, I’ve just tried to run a previously working Golang app, an I am getting the same message.

I did have some issues a couple of versions ago when I inadvertently use homebrew to upgrade, but I was able to fix that eventually. Since the all upgrades have been by downloading the .pkg file and running it.

How embarrassing! It seems that my last upgrade to 1.9.0 must have been using Homebrew. I must be getting old because I don’t remember doing that at all, and following my last hassle with homebrew, I vowed not to use Homebrew for Golang again.

Anyhow, I ran homebrew upgrade go and all was well!

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.