Free PAAS for golang

I started learning golang this year. Gets to do real apps that needs to be hosted for awhile while being tested.
Tutorial suggested app engine.
But me trying app engine don’t work.
First of all, the goapp command don’t work.
Terminal output:
goapp: command not found
Tried gcloud but won’t work without billing account.
What can I do?
Is there any other PAAS alternative to app engine apart from heroku?

goapp: command not found

This sounds like goapp either is not installed properly, or is not included in your PATH environment variable.

  • Verify if you can find the goapp binary on your disk. If you cannot find it, try reinstalling the SDK.
  • If goapp exists, try to start it through its full path name. Also verify if the path to goapp is included in the PATH variable.

About cloud computing services with a free tier: I think these are really rare, but there are many services that start at a very low fee (like $5 or even $2.50 per month - Vultr, Digital Ocean, Linode, and the like).

And if the goal is to learn network stuff like REST, Web Apps, distributed computing, etc., consider running a virtual machine locally on your computer (e.g. using VirtualBox). This has all it needs to test hosted apps - a separate machine (albeit virtual), a server OS of your choice, and an IP network between your computer and the virtual machine.

okay so how do i do that? @christophberger

Thought i could have something heroku. Or to use heroku
But any time i try to use commands, e.g glide or godep it doesn’t work.
So I don’t know if it’s my OS issue.

Heroku supports apps who’s dependencies are vendored with govendor, godep & GB. The buildpack also supports glide, but support requests related to bulding with glide have to be handled via issues on the buildpack repo (

If you can be more specific as to the errors you get with glide, godep, govendor, or GB maybe I can help further here if it’s errors you are getting on your local machine (vs. when pushing to Heroku; a support ticket is the best place to handle those).


any time i try to use commands, e.g glide or godep it doesn’t work.

Do you get the same error message as with goapp - that is, “command not found”?

In this case, this sounds like a PATH issue. Tools like glide or godep are usually installed via go get. In this case, they get compiled into $GOPATH/bin (or %GOPATH%\bin if you use Windows.) If the GOPATH variable is not set on your system, type go env GOPATH to get the current GOPATH (e.g. “/home/myusername/go”).

Then list the contents of the bin subdirectory (e.g. “/home/myusername/go/bin”) to see if glide, godep etc. reside there.

If this is the case, then you need to add the path to this bin directory to your PATH. How to do this is different for each OS and each shell (bash vs zsh vs fish vs elvish vs…), so I cannot provide details at this point.
And I cannot comment on goapp, as I don’t know how it is installed. I assume this comes with the Google Cloud SDK (which I never used myself so far), so you might want to check the SDK documentation.

1 Like

wow… that’s a lot of info there.
I did:
and it worked but i have this in my .bashrc:
export PATH=$PATH:/usr/local/go/bin:/$HOME/go/src
So I don’t know why? followed the docs.
Thanks a lot @christophberger

Try changing /$HOME/go/src to $HOME/go/bin.
If this does not help, enter

go env GOPATH


echo $HOME/go

and verify if both commands deliver the same output. The value of go env GOPATH is the one that the go command uses, so if it differs from $HOME/go, use $(go env GOPATH)/bin in your PATH setting instead.

thanks @christophberger

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.