Erros "3 go setup calls" GoLand IDE

I’m getting this error “3 go setup calls” althoug installed sdk.

SDK : go1.9.2 linux/amd64

1 Like

Did you setup the go environment properly, I mean sdk path etc. I had similar problem to but since I am referring to Todd McLodd Tutorials I just followed the instructions and everything went fine.

What is the a:? Do you want this?
fmt.Println("a: test")



1 Like

Did u tried changing the line from fmt.Println(a: “test”) to fmt.Println(“a: test”)?

Yeah but the editor automatically puts “a” . As far as I know, the function will display the parameter.

1 Like

Did you tried different IDE like Jetbrains webstorm or some other?

No, I go to the required directory with terminal and run the following command,

“go run main.go”

errors : ~/Desktop/go$ go run main.go
package main:
main.go:1:9: expected ‘IDENT’, found 'go’
main.go:3:1: expected ‘;’, found ‘import’

1 Like

Can u share the code which u r trying to run?. But first, follow these below links and check whether u installed go correctly on linux:-

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.