Binary not working on different machine

I have a basic web application I’ve built (my first GoLang app). I have run the build command, and all works well when I run from my development machine. When I run it on my target machine, the console app just opens/quits immediately. My dev machine is Windows10, and target machine is Server2012. No errors in the event viewer. I have tried to run as administrator, with no appreciable difference. Any ideas on what could be happening, or what I can do to get my app to produce some data on why it’s failing? Sorry if this is a dumb question, this is my first stab at GoLang.

1 Like

A first thought: Access rights. Maybe the user account that starts the Go binary perhaps has admin rights on the dev machine but not on the target machine.
(On the other hand, I would at least expect some kind of error message in this case.)

@n8.m, try downloading the golang package again. Choose install location C:\go

Do you start it with a doubleclick on the target machine? Have you tried starting it from the command prompt?

It is a known and common problem that windows runs and closes terminals after the program has quit. To avoid this, you have to open a terminal manually and start the program from there. Perhaps you will see some errors then.


I was doubleclicking it to start it. Although that in itself wasn’t the problem. When I started my golang app via a cmd prompt… It yielded an error. I was able to resolve the error and it runs beautifully now. The actual error was me being too clever with the mux. Thank you everyone who replied and offered some ideas. Much appreciated.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.